psp_20070626.jpg

A firmware downgrader for version 3.50 of the Play Station Portable firmware was just released today! It makes use of an exploit that was recently discovered in the Lumines game, which you’ll have to buy a copy of to make it work. This means that anyone with v3.50 or lower firmware (currently everyone) can now run homebrew games and software (including Linux) on the PSP.

Note that until a firmware revert tool is developed, users with TA-082 or later motherboards will be unable to update to the latest official Sony firmware after this patch is applied.

Downgrader for PSP v3.50 firmware – Link